$re = '/^[A-Za-z\.\/]+( |%20|\+)(eq|gt)( |%20|\+)[\d\-]+(T[\d:]+(\.[\d]+)?Z|Z( [a-z]+ [\d\-]+Z)?)$/m';
$str = 'aaa.com/activityDateTime eq 2022-05-12Z
aaa.com/activityDateTime eq 2022-05-12T12:00:00Z
aaa.com/activityDateTime%20eq%202022-05-12T12:00:00Z
aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456Z
aaa.com/activityDateTime gt 2022-03-12Z le 2022-05-12Z
aaa.com/activityDateTime eq 2022-05-12
aaa.com/activityDateTime eq 2022-05-12T12:00:00
aaa.com/activityDateTime%20eq%202022-05-12T12:00:00
aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);