use strict;
my $str = 'aaa.com/activityDateTime eq 2022-05-12Z
aaa.com/activityDateTime eq 2022-05-12T12:00:00Z
aaa.com/activityDateTime%20eq%202022-05-12T12:00:00Z
aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456Z
aaa.com/activityDateTime gt 2022-03-12Z le 2022-05-12Z
aaa.com/activityDateTime eq 2022-05-12
aaa.com/activityDateTime eq 2022-05-12T12:00:00
aaa.com/activityDateTime%20eq%202022-05-12T12:00:00
aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456
';
my $regex = qr/^[A-Za-z\.\/]+( |%20|\+)(eq|gt)( |%20|\+)[\d\-]+(T[\d:]+(\.[\d]+)?Z|Z( [a-z]+ [\d\-]+Z)?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}