import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z\\.\\/]+( |%20|\\+)(eq|gt)( |%20|\\+)[\\d\\-]+(T[\\d:]+(\\.[\\d]+)?Z|Z( [a-z]+ [\\d\\-]+Z)?)$";
final String string = "aaa.com/activityDateTime eq 2022-05-12Z\n"
+ "aaa.com/activityDateTime eq 2022-05-12T12:00:00Z\n"
+ "aaa.com/activityDateTime%20eq%202022-05-12T12:00:00Z\n"
+ "aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456Z\n"
+ "aaa.com/activityDateTime gt 2022-03-12Z le 2022-05-12Z\n\n\n"
+ "aaa.com/activityDateTime eq 2022-05-12\n"
+ "aaa.com/activityDateTime eq 2022-05-12T12:00:00\n"
+ "aaa.com/activityDateTime%20eq%202022-05-12T12:00:00\n"
+ "aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}