// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z\.\/]+( |%20|\+)(eq|gt)( |%20|\+)[\d\-]+(T[\d:]+(\.[\d]+)?Z|Z( [a-z]+ [\d\-]+Z)?)$").unwrap();
let string = "aaa.com/activityDateTime eq 2022-05-12Z
aaa.com/activityDateTime eq 2022-05-12T12:00:00Z
aaa.com/activityDateTime%20eq%202022-05-12T12:00:00Z
aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456Z
aaa.com/activityDateTime gt 2022-03-12Z le 2022-05-12Z
aaa.com/activityDateTime eq 2022-05-12
aaa.com/activityDateTime eq 2022-05-12T12:00:00
aaa.com/activityDateTime%20eq%202022-05-12T12:00:00
aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}