using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z\.\/]+( |%20|\+)(eq|gt)( |%20|\+)[\d\-]+(T[\d:]+(\.[\d]+)?Z|Z( [a-z]+ [\d\-]+Z)?)$";
string input = @"aaa.com/activityDateTime eq 2022-05-12Z
aaa.com/activityDateTime eq 2022-05-12T12:00:00Z
aaa.com/activityDateTime%20eq%202022-05-12T12:00:00Z
aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456Z
aaa.com/activityDateTime gt 2022-03-12Z le 2022-05-12Z
aaa.com/activityDateTime eq 2022-05-12
aaa.com/activityDateTime eq 2022-05-12T12:00:00
aaa.com/activityDateTime%20eq%202022-05-12T12:00:00
aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}