package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z\.\/]+( |%20|\+)(eq|gt)( |%20|\+)[\d\-]+(T[\d:]+(\.[\d]+)?Z|Z( [a-z]+ [\d\-]+Z)?)$`)
var str = `aaa.com/activityDateTime eq 2022-05-12Z
aaa.com/activityDateTime eq 2022-05-12T12:00:00Z
aaa.com/activityDateTime%20eq%202022-05-12T12:00:00Z
aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456Z
aaa.com/activityDateTime gt 2022-03-12Z le 2022-05-12Z
aaa.com/activityDateTime eq 2022-05-12
aaa.com/activityDateTime eq 2022-05-12T12:00:00
aaa.com/activityDateTime%20eq%202022-05-12T12:00:00
aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}