# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-Za-z\.\/]+( |%20|\+)(eq|gt)( |%20|\+)[\d\-]+(T[\d:]+(\.[\d]+)?Z|Z( [a-z]+ [\d\-]+Z)?)$"
test_str = ("aaa.com/activityDateTime eq 2022-05-12Z\n"
"aaa.com/activityDateTime eq 2022-05-12T12:00:00Z\n"
"aaa.com/activityDateTime%20eq%202022-05-12T12:00:00Z\n"
"aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456Z\n"
"aaa.com/activityDateTime gt 2022-03-12Z le 2022-05-12Z\n\n\n"
"aaa.com/activityDateTime eq 2022-05-12\n"
"aaa.com/activityDateTime eq 2022-05-12T12:00:00\n"
"aaa.com/activityDateTime%20eq%202022-05-12T12:00:00\n"
"aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.