re = /(<[^>]*>)+([a-z][a-z ]+)/i
str = '<a href="http://domain.com/path" target="_blank">GSPd å½¹ã«ç«‹ã¤ãƒ„ール: スã‚ãƒ«æ„æ¬²ãƒžãƒˆãƒªã‚¯ã‚¹</a>'
subst = '$1<span class="text=arial">$2</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result