import Foundation
let pattern = #"(<[^>]*>)+([a-z][a-z ]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"<a href="http://domain.com/path" target="_blank">GSPd å½¹ã«ç«‹ã¤ãƒ„ール: スã‚ãƒ«æ„æ¬²ãƒžãƒˆãƒªã‚¯ã‚¹</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<span class="text=arial">$2</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)