// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(<[^>]*>)+([a-z][a-z ]+)").unwrap();
let string = "<a href=\"http://domain.com/path\" target=\"_blank\">GSPd å½¹ã«ç«‹ã¤ãƒ„ール: スã‚ãƒ«æ„æ¬²ãƒžãƒˆãƒªã‚¯ã‚¹</a>";
let substitution = "$1<span class=\"text=arial\">$2</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}