import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "s\\.prop42=\"([^\"]*)\"";
final String string = "s.prop39=\"\"\n"
+ "s.prop40=\"53\"\n"
+ "s.prop41=\"Anonymous\"\n"
+ "s.prop42=\"username\"\n"
+ "s.prop43=\"\"\n"
+ "s.prop47=\"\"\n";
final String subst = "$0 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}