import re
regex = re.compile(r"s\.prop42=\"([^\"]*)\"")
test_str = ("s.prop39=\"\"\n"
"s.prop40=\"53\"\n"
"s.prop41=\"Anonymous\"\n"
"s.prop42=\"username\"\n"
"s.prop43=\"\"\n"
"s.prop47=\"\"\n")
subst = "$0 "
result = regex.sub(subst, test_str)
if result:
print(result)