re = /s\.prop42="([^"]*)"/
str = 's.prop39=""
s.prop40="53"
s.prop41="Anonymous"
s.prop42="username"
s.prop43=""
s.prop47=""
'
subst = '$0 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result