const regex = /s\.prop42="([^"]*)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('s\\.prop42="([^"]*)"', 'g')
const str = `s.prop39=""
s.prop40="53"
s.prop41="Anonymous"
s.prop42="username"
s.prop43=""
s.prop47=""
`;
const subst = `$0 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);