// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"s\.prop42="([^"]*)""#).unwrap();
let string = "s.prop39=\"\"
s.prop40=\"53\"
s.prop41=\"Anonymous\"
s.prop42=\"username\"
s.prop43=\"\"
s.prop47=\"\"
";
let substitution = "$0 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}