use strict;
my $str = 's.prop39=""
s.prop40="53"
s.prop41="Anonymous"
s.prop42="username"
s.prop43=""
s.prop47=""
';
my $regex = qr/s\.prop42="([^"]*)"/p;
my $subst = '$0 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";