$re = '/s\.prop42="([^"]*)"/';
$str = 's.prop39=""
s.prop40="53"
s.prop41="Anonymous"
s.prop42="username"
s.prop43=""
s.prop47=""
';
$subst = "$0 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;