# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@\[(\w+)\]\(id\:\s(\d+)\)/<a href="view\/\2">@\1<\/a>/gi;t' <<< "He is @[otheruser](id: 100) and he is..
"