using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@\[(\w+)\]\(id\:\s(\d+)\)";
string substitution = @"<a href=""view/\2"">@\1</a>";
string input = @"He is @[otheruser](id: 100) and he is..
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}