# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"@\[(\w+)\]\(id\:\s(\d+)\)"
test_str = ("He is @[otheruser](id: 100) and he is..\n")
subst = "<a href=\"view/\\2\">@\\1</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.