use strict;
my $str = 'He is @[otheruser](id: 100) and he is..
';
my $regex = qr/@\[(\w+)\]\(id\:\s(\d+)\)/ip;
my $subst = '<a href="view/\\2">@\\1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";