#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)@\[(\w+)\]\(id\:\s(\d+)\)"
Local $sString = "He is @[otheruser](id: 100) and he is.." & @CRLF & _
""
Local $sSubst = "<a href="view/\2">@\1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)