$re = '/@\[(\w+)\]\(id\:\s(\d+)\)/i';
$str = 'He is @[otheruser](id: 100) and he is..
';
$subst = "<a href=\"view/\2\">@\1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;