package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)@\[(\w+)\]\(id\:\s(\d+)\)`)
var str = `He is @[otheruser](id: 100) and he is..
`
var substitution = "<a href="view/\2">@\1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}