package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s{2,}`)
var str = `AALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}