$re = '/\s{2,}/';
$str = 'AALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR
A ALL YEAR';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;