import re
regex = re.compile(r"\s{2,}")
test_str = ("AALL YEAR\n"
"A ALL YEAR\n"
"A ALL YEAR\n"
"A ALL YEAR\n"
"A ALL YEAR\n"
"A ALL YEAR")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)