#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<input type="hidden" value="(.*?)" name="_csrf">"
Local $sString = "<input type="hidden" value="a5a40c7c-232e-47e5-9059-964af24933e9" name="_csrf">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")