const regex = /<input type="hidden" value="(.*?)" name="_csrf">/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<input type="hidden" value="(.*?)" name="_csrf">', '')
const str = `<input type="hidden" value="a5a40c7c-232e-47e5-9059-964af24933e9" name="_csrf">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}