import re
regex = re.compile(r"<input type=\"hidden\" value=\"(.*?)\" name=\"_csrf\">")
test_str = "<input type=\"hidden\" value=\"a5a40c7c-232e-47e5-9059-964af24933e9\" name=\"_csrf\">"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")