$re = '/<input type="hidden" value="(.*?)" name="_csrf">/';
$str = '<input type="hidden" value="a5a40c7c-232e-47e5-9059-964af24933e9" name="_csrf">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);