#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\?(firstName|lastName|email|phone1|address)=([^&]*(?:&[^&=]+(?=&|$))*)(?:&|$)"
Local $sString = "https://example.com?email=abc&xyz@.com&isAvailableReferral=true" & @CRLF & _
"https://example.com?email=abc@xyz.com&isAvailableReferral=true" & @CRLF & _
"https://example.com?email=abc&xyz@.com" & @CRLF & _
"https://example.com?email=abc@xyz.com" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)