use strict;
my $str = 'https://example.com?email=abc&xyz@.com&isAvailableReferral=true
https://example.com?email=abc@xyz.com&isAvailableReferral=true
https://example.com?email=abc&xyz@.com
https://example.com?email=abc@xyz.com
';
my $regex = qr/\?(firstName|lastName|email|phone1|address)=([^&]*(?:&[^&=]+(?=&|$))*)(?:&|$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";