import re
regex = re.compile(r"\?(firstName|lastName|email|phone1|address)=([^&]*(?:&[^&=]+(?=&|$))*)(?:&|$)", flags=re.MULTILINE)
test_str = ("https://example.com?email=abc&xyz@.com&isAvailableReferral=true\n"
"https://example.com?email=abc@xyz.com&isAvailableReferral=true\n"
"https://example.com?email=abc&xyz@.com\n"
"https://example.com?email=abc@xyz.com\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)