$re = '/\?(firstName|lastName|email|phone1|address)=([^&]*(?:&[^&=]+(?=&|$))*)(?:&|$)/m';
$str = 'https://example.com?email=abc&xyz@.com&isAvailableReferral=true
https://example.com?email=abc@xyz.com&isAvailableReferral=true
https://example.com?email=abc&xyz@.com
https://example.com?email=abc@xyz.com
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;