re = /\?(firstName|lastName|email|phone1|address)=([^&]*(?:&[^&=]+(?=&|$))*)(?:&|$)/m
str = 'https://example.com?email=abc&xyz@.com&isAvailableReferral=true
https://example.com?email=abc@xyz.com&isAvailableReferral=true
https://example.com?email=abc&xyz@.com
https://example.com?email=abc@xyz.com
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result