const regex = /\?(firstName|lastName|email|phone1|address)=([^&]*(?:&[^&=]+(?=&|$))*)(?:&|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\?(firstName|lastName|email|phone1|address)=([^&]*(?:&[^&=]+(?=&|$))*)(?:&|$)', 'gm')
const str = `https://example.com?email=abc&xyz@.com&isAvailableReferral=true
https://example.com?email=abc@xyz.com&isAvailableReferral=true
https://example.com?email=abc&xyz@.com
https://example.com?email=abc@xyz.com
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);