#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:https?:\/\/www\.|https?:\/\/|www\.|^)([A-z0-9.]+)"
Local $sString = "https://www.one1.com/?utm_source=bubb" & @CRLF & _
"http://www.one2.io/?utm_source=hjyy" & @CRLF & _
"http://one3.ru?utm_source=dfgh" & @CRLF & _
"https://one4.com/" & @CRLF & _
"http://www.one5.io/?utm_source=hjyy" & @CRLF & _
"www.one6.io"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")