const regex = /(?:https?:\/\/www\.|https?:\/\/|www\.|^)([A-z0-9.]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https?:\\\/\\\/www\\.|https?:\\\/\\\/|www\\.|^)([A-z0-9.]+)', 'gm')
const str = `https://www.one1.com/?utm_source=bubb
http://www.one2.io/?utm_source=hjyy
http://one3.ru?utm_source=dfgh
https://one4.com/
http://www.one5.io/?utm_source=hjyy
www.one6.io`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}