package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:https?:\/\/www\.|https?:\/\/|www\.|^)([A-z0-9.]+)`)
var str = `https://www.one1.com/?utm_source=bubb
http://www.one2.io/?utm_source=hjyy
http://one3.ru?utm_source=dfgh
https://one4.com/
http://www.one5.io/?utm_source=hjyy
www.one6.io`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}