import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?:\\/\\/www\\.|https?:\\/\\/|www\\.|^)([A-z0-9.]+)";
final String string = "https://www.one1.com/?utm_source=bubb\n"
+ "http://www.one2.io/?utm_source=hjyy\n"
+ "http://one3.ru?utm_source=dfgh\n"
+ "https://one4.com/\n"
+ "http://www.one5.io/?utm_source=hjyy\n"
+ "www.one6.io";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}