$re = '/(?:https?:\/\/www\.|https?:\/\/|www\.|^)([A-z0-9.]+)/m';
$str = 'https://www.one1.com/?utm_source=bubb
http://www.one2.io/?utm_source=hjyy
http://one3.ru?utm_source=dfgh
https://one4.com/
http://www.one5.io/?utm_source=hjyy
www.one6.io';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);