use strict;
my $str = 'https://www.one1.com/?utm_source=bubb
http://www.one2.io/?utm_source=hjyy
http://one3.ru?utm_source=dfgh
https://one4.com/
http://www.one5.io/?utm_source=hjyy
www.one6.io';
my $regex = qr/(?:https?:\/\/www\.|https?:\/\/|www\.|^)([A-z0-9.]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}