import re
regex = re.compile(r"(?:https?:\/\/www\.|https?:\/\/|www\.|^)([A-z0-9.]+)", flags=re.MULTILINE)
test_str = ("https://www.one1.com/?utm_source=bubb\n"
"http://www.one2.io/?utm_source=hjyy\n"
"http://one3.ru?utm_source=dfgh\n"
"https://one4.com/\n"
"http://www.one5.io/?utm_source=hjyy\n"
"www.one6.io")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")