using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https?:\/\/www\.|https?:\/\/|www\.|^)([A-z0-9.]+)";
string input = @"https://www.one1.com/?utm_source=bubb
http://www.one2.io/?utm_source=hjyy
http://one3.ru?utm_source=dfgh
https://one4.com/
http://www.one5.io/?utm_source=hjyy
www.one6.io";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}