#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w-]+@[\w]+(\.[a-z0-9]{2,4}){1,3}$"
Local $sString = "tuan201200387@st.utc.edu.vn" & @CRLF & _
"tuan@gmail.com" & @CRLF & _
"Tuan_123@gmai.edu.com" & @CRLF & _
"tuan?123@gmail.vn" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"!@$#@$^$@^%123Tun.edu.vn" & @CRLF & _
"Tuan#$#%^%#^@#@.vn " & @CRLF & _
"Tuan.vn" & @CRLF & _
"abCdEF@.edu.@#%^$^$.vn" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")