import Foundation
let pattern = #"^[\w-]+@[\w]+(\.[a-z0-9]{2,4}){1,3}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
tuan201200387@st.utc.edu.vn
tuan@gmail.com
Tuan_123@gmai.edu.com
tuan?123@gmail.vn
!@$#@$^$@^%123Tun.edu.vn
Tuan#$#%^%#^@#@.vn
Tuan.vn
abCdEF@.edu.@#%^$^$.vn
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)