import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w-]+@[\\w]+(\\.[a-z0-9]{2,4}){1,3}$";
final String string = "tuan201200387@st.utc.edu.vn\n"
+ "tuan@gmail.com\n"
+ "Tuan_123@gmai.edu.com\n"
+ "tuan?123@gmail.vn\n\n\n"
+ "!@$#@$^$@^%123Tun.edu.vn\n"
+ "Tuan#$#%^%#^@#@.vn \n"
+ "Tuan.vn\n"
+ "abCdEF@.edu.@#%^$^$.vn\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}