re = /^[\w-]+@[\w]+(\.[a-z0-9]{2,4}){1,3}$/m
str = 'tuan201200387@st.utc.edu.vn
tuan@gmail.com
Tuan_123@gmai.edu.com
tuan?123@gmail.vn
!@$#@$^$@^%123Tun.edu.vn
Tuan#$#%^%#^@#@.vn
Tuan.vn
abCdEF@.edu.@#%^$^$.vn
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end