$re = '/^[\w-]+@[\w]+(\.[a-z0-9]{2,4}){1,3}$/m';
$str = 'tuan201200387@st.utc.edu.vn
tuan@gmail.com
Tuan_123@gmai.edu.com
tuan?123@gmail.vn
!@$#@$^$@^%123Tun.edu.vn
Tuan#$#%^%#^@#@.vn
Tuan.vn
abCdEF@.edu.@#%^$^$.vn
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);